Seguimi su Youtubue
Iscriviti
Se desideri, puoi effettuare un'iscrizione gratuita al forum per entrare nella nostra community.
Ricerca Avanzata
Pubblicità Google AdSense
Answers
Se necessiti di aiuto, clicca il pulsante "Cerco Aiuto" (disponibile anche per i non iscritti).
Ultimi argomenti
» Come realizzare un impianto antincendio con Arduino - v1.0
Da papat Ieri a 11:47 am

» Sketch per realizzare un semplice semaforo con Arduino
Da Poderak Dom Feb 26, 2017 6:27 pm

» problemi con stazione meteo e schema arduino
Da Poderak Dom Feb 26, 2017 6:23 pm

» Ethernet Shiel compatibile non pinga
Da Poderak Mer Feb 22, 2017 10:03 am

» FUNZIONE I2C
Da papat Dom Feb 19, 2017 6:21 pm

» Come controllare motori DC con L298N e Arduino
Da Poderak Mer Feb 15, 2017 2:14 pm

» Recensione mini drone Aukey - Video
Da Poderak Sab Feb 11, 2017 7:05 pm

» Recensione gamepad Xbox per PC EasySMX - Video recensione
Da Poderak Sab Feb 11, 2017 7:03 pm

» Lampada tech Aukey LT-T6 - Video recensione
Da Poderak Sab Feb 11, 2017 7:02 pm

I postatori più attivi del mese
Poderak
 
papat
 
Mrskizzo
 
SistemaL
 
Charade
 

Arduino dimentica sketch ricollegandolo

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Arduino dimentica sketch ricollegandolo

Messaggio Da Poderak il Gio Mar 24, 2016 12:54 pm

In questo post volevo raccontarvi la mia esperienza riguardo un Arduino Uno che dimenticava gli sketch. Per fortuna il problema sono riuscito a "risolverlo". In pratica appena lo scollegavo e poi lo ricollegavo al computer, l'Arduino dimenticava lo sketch ed il led (PIN 13) lampeggiava due volte velocemente ogni secondo.

La scheda in questione è il Tamino mentre su altre schede, non mi è capitato. Navigando in rete ho cercato qualche soluzione ma purtroppo nessuna ha dato esito positivo. Come ultima soluzione ho addirittura provato a fare il bootloader ma anch'essa senza esiti positivi. L'Arduino continuava ad avere una sorta di amnesia non appena si scollegava e ricollegava al computer.

Ormai convinto di buttare la scheda, decisi di collegarlo in un altro computer. Magia! L'Arduino non ha più il problema. Che cosa può essere allora? Sarà il mio computer? A questo punto decisi di prendere un'alimentazione esterna e anche con quella l'Arduino (il Tamino) funzionava correttamente. Invece, se lo collegavo nel computer dove dava problemi, continuava ad avere la sua amnesia (apparente dato che se lo collegavo da un'altra parte lo sketch veniva eseguito).

A questo punto pensavo fossero le porte USB del computer difettate anche se mi sembrava MOOOOLTO strano in quanto gli altri Arduino funzionavano tranquillamente. A questo punto decisi di riavviare il computer e voilà, l'Arduino (il Tamino) finalmente torna a funzionare. Non è finita però. Aprendo l'IDE 1.6.8 scopro che il problema era risorto. Finalmente ho capito che il problema era proprio l'IDE che in qualche modo faceva andare in tilt la scheda. Tornando ad una versione precedente dell'IDE, ho risolto il problema.

A quanto pare è un bug dell'IDE 1.6.8 in quanto comunque mi caricava gli sketch nell'Arduino "difettoso" e finché rimaneva collegato, nessun problema. Però quando lo scollegavo e ricollegavo, aveva una sorta di amnesia. Tornando ad una versione precedente, presente sul sito di Arduino.cc, sono riuscito a risolvere il problema e ha funzionato tutto correttamente come prima.

Poderak
♔ Amministratore

Messaggi Messaggi : 4136
Crediti Crediti : 11626
Reputazione Reputazione : 185
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 18
Località Località : Brescia

Vedere il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto


 
Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum