Seguimi su Youtubue
Iscriviti
Se desideri, puoi effettuare un'iscrizione gratuita al forum per entrare nella nostra community.
Accedi

Recuperare la parola d'ordine

Ricerca Avanzata
Pubblicità Google AdSense
Answers
Se necessiti di aiuto, clicca il pulsante "Cerco Aiuto" (disponibile anche per i non iscritti).
Ultimi argomenti
» Dove acquistare relè arduino
Da Ilfalco78 Ieri a 10:25 am

» Logger sito web in PHP in file txt
Da Poderak Sab Gen 14, 2017 11:16 am

» Recensione caricabatteria iVoler con 2 porte USB 24W 4.8A
Da Poderak Dom Gen 08, 2017 9:57 pm

» Recensione cuffie da gaming: Thrustmaster 300CPX (Doom Edition)
Da Poderak Sab Dic 24, 2016 10:51 pm

» Problemi connessione arduino compatibile
Da Poderak Mer Dic 21, 2016 1:53 pm

» Recensione Speaker Bluetooth - Anker SoundCore Mini
Da Poderak Sab Dic 17, 2016 4:44 pm

» Arduino + telecamera
Da Poderak Mar Dic 13, 2016 6:36 pm

» PRESENTATI AL FORUM
Da Poderak Mar Dic 13, 2016 4:07 pm

» Recensione Filo - Il portachiavi tech
Da Poderak Sab Dic 10, 2016 5:24 pm

I postatori più attivi del mese
Poderak
 
Ilfalco78
 

Arduino dimentica sketch ricollegandolo

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Arduino dimentica sketch ricollegandolo

Messaggio Da Poderak il Gio Mar 24, 2016 12:54 pm

In questo post volevo raccontarvi la mia esperienza riguardo un Arduino Uno che dimenticava gli sketch. Per fortuna il problema sono riuscito a "risolverlo". In pratica appena lo scollegavo e poi lo ricollegavo al computer, l'Arduino dimenticava lo sketch ed il led (PIN 13) lampeggiava due volte velocemente ogni secondo.

La scheda in questione è il Tamino mentre su altre schede, non mi è capitato. Navigando in rete ho cercato qualche soluzione ma purtroppo nessuna ha dato esito positivo. Come ultima soluzione ho addirittura provato a fare il bootloader ma anch'essa senza esiti positivi. L'Arduino continuava ad avere una sorta di amnesia non appena si scollegava e ricollegava al computer.

Ormai convinto di buttare la scheda, decisi di collegarlo in un altro computer. Magia! L'Arduino non ha più il problema. Che cosa può essere allora? Sarà il mio computer? A questo punto decisi di prendere un'alimentazione esterna e anche con quella l'Arduino (il Tamino) funzionava correttamente. Invece, se lo collegavo nel computer dove dava problemi, continuava ad avere la sua amnesia (apparente dato che se lo collegavo da un'altra parte lo sketch veniva eseguito).

A questo punto pensavo fossero le porte USB del computer difettate anche se mi sembrava MOOOOLTO strano in quanto gli altri Arduino funzionavano tranquillamente. A questo punto decisi di riavviare il computer e voilà, l'Arduino (il Tamino) finalmente torna a funzionare. Non è finita però. Aprendo l'IDE 1.6.8 scopro che il problema era risorto. Finalmente ho capito che il problema era proprio l'IDE che in qualche modo faceva andare in tilt la scheda. Tornando ad una versione precedente dell'IDE, ho risolto il problema.

A quanto pare è un bug dell'IDE 1.6.8 in quanto comunque mi caricava gli sketch nell'Arduino "difettoso" e finché rimaneva collegato, nessun problema. Però quando lo scollegavo e ricollegavo, aveva una sorta di amnesia. Tornando ad una versione precedente, presente sul sito di Arduino.cc, sono riuscito a risolvere il problema e ha funzionato tutto correttamente come prima.

Poderak
♔ Amministratore

Messaggi Messaggi : 4115
Crediti Crediti : 11590
Reputazione Reputazione : 185
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 18
Località Località : Brescia

Vedere il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto


 
Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum