Recensisci!
Diventa un recensore per ricevere prodotti gratuiti o scontati!
Iscriviti
Se desideri, puoi effettuare un'iscrizione gratuita al forum per entrare nella nostra community.
Ricerca Avanzata
Pubblicità Amazon
Answers
Se necessiti di aiuto, clicca il pulsante "Cerco Aiuto" (disponibile anche per i non iscritti).
Ultimi argomenti
» Meglio Android o iOS? Video spiegazione
Da Admin Ven Nov 17, 2017 9:52 pm

» Primo gameplay Platinum Edition - Farming Simulator 2017
Da Admin Ven Nov 17, 2017 9:47 pm

» Errore sketch braccio robotico
Da papat Mer Nov 15, 2017 3:39 pm

» Miglior smartphone sotto i €150 - 2017
Da Admin Sab Nov 11, 2017 10:50 am

» Miglior smartphone sotto i €100 - 2017
Da Admin Ven Nov 10, 2017 10:10 pm

» Recensione protettore RFID
Da Entop Dom Ott 29, 2017 10:01 pm

» Presentati al forum
Da Entop Dom Ott 29, 2017 9:40 pm

» Formato delle recensioni Amazon consigliato
Da Admin Dom Ott 29, 2017 4:12 pm

» Come localizzare in diretta i propri contatti di Whatsapp
Da Admin Sab Ott 28, 2017 9:35 pm

I postatori più attivi del mese
Admin
 
papat
 

Problemi con effetto Fade con Arduino

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Mar Giu 14, 2016 9:16 pm

ciao e da un po' che sto diventando pazzo per riuscire a dimorare una uscita (pwd) tramite bluetooth con il mio iPhone utilizzando l'app bluetuino. per il momento riesco ad accendere led spegnere ecc  ma non riesco ad usare il fade non so propio come fare, ho cercato di smembrare altri codici che fanno una cosa simile ma senza successo, vorrei sapere se mi puoi aiutare a capire come fare


grazie in anticipo 
vic.
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Mer Giu 15, 2016 9:04 am

Ciao @vcr3ak,

Prima di tutto devi sapere che per fare un effetto fade con Arduino dovrai utilizzare i PIN PWM (quelli contrassegnati dall'ondicina). Da un punto di vista software invece, non dovrai più usare digitalWrite(led, HIGH); ma bensì analogWrite(led, valore);

Dai un'occhiata a questo tutorial qui.

Fammi sapere Ciao!
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Mer Giu 15, 2016 1:47 pm

Ciao. Grazie per la tua risposta. La parte di analogwrite e le uscite pwm le ho capite bene ma forse ho usato il termine sbagliato dicendo efetto fade anzi che dimmer. Infatti quello che vorrei fare e' dimmerare un led tramite bluetuino, quindi usando una scala da 0>255 e viceversa.
Ho provato quello che mi hai postato. ed e' funzionato
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Mer Giu 15, 2016 4:03 pm

Tipo questo ma gestito con app via Bluetooth? Very Happy
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Mer Giu 15, 2016 8:52 pm

avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Mer Giu 15, 2016 8:57 pm

@vcr3ak i messaggi sono vuoti. E' normale?
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Mer Giu 15, 2016 11:16 pm

chiedo scusa, ho provato a risponder dal telefonino ma mi sa' che non ha funzionato.
comunque top! mi riferisco propio a quello che mi hai postato ma appunto da bluetooth, ho guardato il tutorial almeno 5 volte e ho cercato di adattarlo con il serial.read ma ho fatto solo casino perché non sono stato i grado.
grazie grazie grazie per darmi retta.
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Gio Giu 16, 2016 11:32 am

Ciao,

Pensi che il problema sia l'applicazione oppure il software di Arduino che hai realizzato Ciao!?
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Gio Giu 16, 2016 4:18 pm

senza dubbio il software (il codice) perche' con un?altro codice di semplice accensione led via bluetooth funziona benissimo, il problema lo riscontro con questo fade o dimmer
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Gio Giu 16, 2016 7:45 pm

Passami lo sketch così lo vediamo insieme alla ricerca dell'errore Very Happy
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Gio Giu 16, 2016 11:45 pm

Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy eheheheh il problema e che non saprei propio cosa scrivere comunque ti mando quello che ho fatto e con quello che riesco a comunicare. ma anziché accendere e spegnere vorrei dimmerare
Codice:

void setup ()
{
  Serial.begin(9600);
  pinMode (2 , OUTPUT);
  pinMode (3, OUTPUT);
  pinMode (4, OUTPUT);
  pinMode (5, OUTPUT);
  pinMode (6, OUTPUT);
  pinMode (7, OUTPUT);
  pinMode (8, OUTPUT);
  pinMode (9, OUTPUT);
  
}
void loop ()
{
  char c = Serial.read();
  if (c == 'A')
  {
    digitalWrite (2, HIGH);
    delay(500);
    digitalWrite (2, LOW);
  }
  
  if (c == 'B')
  
  {
  digitalWrite (3, HIGH);
  delay(500);
  digitalWrite (3, LOW);
  
}


if (c == 'C')
  
  {
  digitalWrite (4, HIGH);
  delay(500);
  digitalWrite (4, LOW);
  
}
if (c == 'D')
  
  {
  digitalWrite (5, HIGH);
  delay(500);
  digitalWrite (5, LOW);
  
}
if (c == 'E')
  
  {
  digitalWrite (6, HIGH);
  delay(500);
  digitalWrite (6, LOW);
  
}
if (c == 'F')

  
  {
  digitalWrite (7, HIGH);
  delay(500);
  digitalWrite (7, LOW);
  
}
    if (c == 'G')
  
  {
  digitalWrite (8, HIGH);
  delay(500);
  digitalWrite (8, LOW);
  
}
  if (c == 'H')
  
  {
  digitalWrite (9, HIGH);
  delay(500);
  digitalWrite (9, LOW);

  
  
  
}

}
  
  
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Ven Giu 17, 2016 10:06 am

Il problema penso proprio che si pone nella parta dell'applicazione Android. Devi trovare un modo che l'app dia valori che vanno da 0 a 255 tramite per esempio una barra scorrevole, da inviare alla lettura di Arduino. Ciao!
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Ven Giu 17, 2016 10:23 am

guarda questa è la schermata dell'app 
si potrebbe fare vero??Very Happy:D:D

avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Ven Giu 17, 2016 12:45 pm

Si, si può fare Ciao!
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Ven Giu 17, 2016 2:26 pm

tu mi potresti aiutare?
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Ven Giu 17, 2016 2:34 pm

Per il software di Arduino sì, per l'applicazione Android perché ancora non ho avuto modo di sviluppare app. Sad
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Ven Giu 17, 2016 3:34 pm

ok ok, va benissimo un aiuto e' sempre un aiuto,magari si riesco a adattarlo con l'app ios, poi se ti devo qualcosa fammi sapere:lol:Very Happy
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Ven Giu 17, 2016 4:56 pm

ma va, non preoccuparti, alla fine è stato solo un consiglio Ciao!
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da vcr3ak il Ven Giu 17, 2016 9:12 pm

quindi mi potresti mandare uno sketch con questa funzione per poi poterlo provare?
avatar
vcr3ak
Livello uno
Livello uno

Messaggi Messaggi : 10
Crediti Crediti : 12
Reputazione Reputazione : 0
Data d'iscrizione Data d'iscrizione : 14.06.16
Età Età : 31

Vedi il profilo dell'utente

Tornare in alto Andare in basso

Re: Problemi con effetto Fade con Arduino

Messaggio Da Admin il Sab Giu 18, 2016 8:43 am

Un esempio di sketch che potresti usare:
Codice:

int led=3;
int potenziometro=A0;
int val=0;
int fade=0;

void setup() {
  pinMode(led, OUTPUT);
  pinMode(potenziometro, INPUT);
}

void loop() {
  //leggo il valore del potenziometro
  val=analogRead(potenziometro);
  //proporziono valore del potenziometro con quello del led
  fade=map(val, 0, 1023, 0, 255);
  //scrivo sul led i valori proporzionati
  analogWrite(led, fade);

}

Dovresti sostituire il PIN "potenziometro" con il valore che invii tramite app. Quindi bisogna adattarlo Very Happy.
avatar
Admin
♔ Amministratore

Messaggi Messaggi : 4224
Crediti Crediti : 11792
Reputazione Reputazione : 186
Data d'iscrizione Data d'iscrizione : 08.03.11
Età Età : 19
Località Località : Brescia

Vedi il profilo dell'utente http://www.wikiinfo.net

Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto


 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum